邮件订阅发送失败机制

观小数发表于:2020年09月09日 19:27:37更新于:2020年09月10日 19:07:55

问题描述:

某用户收到了四封邮件订阅的邮件,但是订阅历史显示是失败的状态,报错信息提示收件人邮箱无效,比如:send email failed due to invalid email address: 123@guandata.com

0015f58c2eb85af59a9063afd0e9e8b

订阅的设置页面如下,可见客户设置的是每天9点发送该订阅:

0015f58c0f1624c7975e70c52d409df


客户收到订阅的邮件如下:


0015f58c55b9cac1e094b3d3dcbe312


原因分析:

该订阅的收件人中,有一个无效地址,导致订阅发送失败,此时触发了订阅失败机制,整个订阅会重新发送,默认是失败后每隔15分钟重发一次 ,一共3次,且所有人都会重发。

所以就出现了地址正常的收件人邮箱可能收到多封邮件的现象。

另外,失败后系统的自动重试,是不在发送历史里展示的,发送历史里展示的是用户设置的定时发送和手动发送的历史。

所以这里只有一条失败的订阅记录。


解决方法:

1、去掉无效邮箱的收件人,该订阅就会正常发送。

2、失败机制是个配置项,可以联系相关人员(如您的专属顾问或售后支持)去查看环境是否有设置失败机制,并根据需要进行配置:

① 如果不想收到重复发送的收件,可以把该机制关闭。

② 如果只想重复发送一次,那就在需要联系观远,在配置项里设置失败重试次数为1次。

    您需要登录后才可以回复